Letux Kernel

Issue 671: Instructions to clone do not work

Reported by Rainer Blome, Dec 6, 2014

The gta04-kernel project's main page
http://projects.goldelico.com/p/gta04-kernel/
says in section "Installation":

 git clone http://git.goldelico.com/?p=gta04-kernel.git

The line continues with other commands ("git checkout", 
"make" etc.) which are not visibly separated from each 
other in any way.
Registering here, I hoped I would at least be able to fix the 
command separation (by enforcing newlines or adding semicolons) on 
that page. However, when logged in, I do not see an "Edit 
page" or "Diese Seite aktualisieren" link. Is this 
not a Wiki page?

On my Cygwin system, the clone command above results in:

----
Cloning into '?p=gta04-kernel'...
fatal: repository 'http://git.goldelico.com/?p=gta04-kernel.git/' 
not found
----

I am fairly sure that this is not an issue specific to my system, as 
it works with other repos.

Trying evasive maneuvres, I went to 
http://projects.goldelico.com/p/gta04-kernel/page/Build/
which lists this command:

 git clone git@github.com:goldelico/gta04-kernel.git

This is greeted with:

----
Cloning into 'gta04-kernel'...
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
----

Maybe I need to register a public key with github.com in order to 
use the git protocol with github.
I might try that next.
If that is so, edit that page to explain this.

Meanwhile, the following command allows cloning
without any additional requirements:

 git clone https://github.com/goldelico/gta04-kernel.git

Comment 1 by Lukas M, Dec 7, 2014

Does this command work for you?
git clone http://git.goldelico.com/gta04-kernel.git

Comment 2 by Rainer Blome, Dec 12, 2014

Yes, that seems to work (interrupted it after a minute or so, no 
need to waste bandwidth as I already have the content).

The "git" protocol works as well, and seems to be quicker 
than HTTP:

 git remote add gd-git git://git.goldelico.com/gta04-kernel.git
 git fetch gd-git

What about the editability of the project's main page?

Comment 3 by Lukas M, Dec 12, 2014

OK, thanks for the feedback!
AFAIK the project main pages can only be edited by the Admin(s), 
i.e. Nikolaus in this case. I'm assigning this issue to him, so he 
can update the URL.
Owner: hns

Comment 4 by Nikolaus Schaller, Dec 22, 2014

has been fixed and tested.
Using http:// should have worked (worked for me) and is almost the 
same as using git://. The difference is that the http protocol is a 
little more robust if the connection breaks down (it does not leave 
a corrupt temporary file).

Please try.
Status: Fixed

Created: 9 years 6 months ago by Rainer Blome

Updated: 9 years 6 months ago

Status: Fixed

Owner: Nikolaus Schaller

Followed by: 1 person

Labels:
Type:Defect
Priority:Medium