Letux Kernel

Issue 707: GTA04: Suspend current consumption still too high!

Reported by Nikolaus Schaller, Nov 25, 2015

Situation:

* we can test suspend through /root/measure-suspend
* on 4.3 kernel it is ~50-58 mA on GTA04 and OpenPandora
* on 3.7 kernel (GTA04 only) it comes down to 20 mA

we do not know what the difference makes, except a hint from 
thermographic imaging that some component in the TPS65950 is still 
getting hot:

http://lists.goldelico.com/pipermail/gta04-owner/2015-October/006814.
html

Comment 1 by Nikolaus Schaller, Nov 25, 2015

Summary: Suspend current consumption still too high!

Comment 2 by Nikolaus Schaller, Nov 25, 2015

Radek tells: There was some alsa fix saving 5mA:

http://lists.goldelico.com/pipermail/gta04-owner/2015-November/006819
.html

Comment 3 by Nikolaus Schaller, Feb 13, 2016

Disabling musb or the phy-twl4030-usb makes the suspend power go 
down by 25 mA. So this means the musb code with the USB client is 
not properly suspending.

Comment 4 by Nikolaus Schaller, Feb 13, 2016

Summary: GTA04: Suspend current consumption still too high!

Comment 5 by Rigoberto Calleja, Feb 13, 2016

Regarding comment #3, I think the following email messages from the 
Gta04-owner list are interesting:

1.- 
http://lists.goldelico.com/pipermail/gta04-owner/2015-December/006912
.html

2.- 
http://lists.goldelico.com/pipermail/gta04-owner/2015-December/006929
.html

Comment 6 by Rigoberto Calleja, Feb 20, 2016

I found these email messages to be interesting:

1.- "We have a new mailing list for Letux kernel 
development:"
http://lists.goldelico.com/pipermail/gta04-owner/2016-February/007029
.html

2.- Letux Linux Kernel v4.5-rc4 is available for testing on GTA04 
& "it has a significant change to phy-twl4030-usb":
http://lists.goldelico.com/pipermail/letux-kernel/2016-February/00004
4.html

Comment 7 by Andreas Kemnade, Feb 16, 2019

current (5.0-rc) known bad boys:
bluetooth (+10mA GTA04A5, +70mA GTA04A4)
so disable bluetooth (no hci0 should be there) if not needed
current record low is around 15mA (w/o modem)

Comment 8 by Nikolaus Schaller, Apr 10, 2020

Suspend issues are even increasing.
It seems as if the OffMode is broken since v5.6-rc1.
Labels: Milestone:5.7

Created: 4 years 6 months ago by Nikolaus Schaller

Updated: 1 month 19 days ago

Status: New

Followed by: 2 persons

Labels:
Type:Defect
Priority:Critical
Milestone:5.7

This issue is related to
472 - Mis...wer management functions